Touch screen problem

Home Surface RT/2 Touch screen problem

This topic contains 2 replies, has 2 voices, and was last updated by John Riggs John Riggs 1 year, 3 months ago.

  • Author
    Posts
  • #203
    Joanna Moderator
    Joanna Moderator
    Keymaster

      Recent question from a reader: I’m sorry, I’m at my wits end and I’m looking all over the internet for answers. I know you stated not to send tech questions, but you have no articles covering this. I used to love my surface 2, but then the touch screen quit working one night after an update. I am reading lots of reports like this online. Microsoft Tech Support even acknowledged this (I have it in writing), however after a list of trouble shooting, no luck in getting it working. We have done a factory reset and reinstalled windows. Their resolution is that this must be a hardware issue….except others are having it at the same time, tech support noted it was a known issue, and it sat on a table overnight, untouched, and somehow the hardware failed? Their response is to just buy a new one, which is infuriating. I plan to try for a few more days of seeking help anywhere I can before filing a BBB claim (I don’t know what else to do). This situation is enough to make me want to go buy an iPad.

    • #276
      Joanna Moderator
      Joanna Moderator
      Keymaster

        Dear Reader,
        So, the touchscreen does not work at all? It must work if you were able to reset to default and reinstall.
        Did you follow the steps in our post http://www.lovemysurface.net/troubleshoot-surface-touch-screen-problems/ already?
        Especially, the step – Check for File Corruption, that could be helpful.
        Otherwise, if MS tech support can’t fix it, I don’t know what else you can do. I assume your device doesn’t have the warranty any longer? If not, they do have an option for repair but it is a for-pay service.
        Good luck.

      • #2384
        John Riggs
        John Riggs
        Participant

          My surface rt had its touchscreen gradually stop working, becoming intermittent, then positional, and then non-functional. Finally I went to the printers and scanners section of the settings and then printers/devices – it showed an error marking over the surface component and offered a troubleshoot. I ran that and rebooted, after which it worked.

          Before all that I went through the algorithm including a surveying the system for corrupted files/sectors (there was one) and a disc check (it didn’t help) before finally doing a factory reset (which didn’t solve my problem OR fix the corrupted entity).

        You must be logged in to reply to this topic.