Turn off type cover touchpad – problem/solution

Home Surface Pro/Pro2 Turn off type cover touchpad – problem/solution

This topic contains 0 replies, has 1 voice, and was last updated by Trude Diamond Trude Diamond 1 month ago.

  • Author
    Posts
  • #2717
    Trude Diamond
    Trude Diamond
    Participant

      Problem: The touchpad sensitivity made the cursor jump around when I typed. I use an arc-mouse for intense writing, so I don’t need the touchpad on with the mouse. Changing the settings (Settings > Devices > Touchpad) to off when mouse is on, or even to entirely off, didn’t deactivate the touchpad. Even Device Manager > Human Interface Devices > HID-compliant touch pad (right click) > Disable Device failed to disable it, even though the touchpad was then removed from the Settings > Devices display!

      I searched this excellent forum for a solution because it had provide a perfect one for the persistent sticky-key problem. It offered the two I’d tried and the option of using the Surface Trackpad Settings app. Downloaded the app, but when I launched it, it sad it couldn’t work on my trackpad and offered several actions to enable it to do so. None worked as directed. All my drivers were up to date. Cursing and chocolate self-medication ensued.

      But persisting in my quest, I found that the app’s instruction to “hit Refresh three times” in the “Search” field when you enter the search term they require will display the message that a problem needs troubleshooting. Run the troubleshooting! When you get the window showing that the problem is fixed, it IS. Your touchpad is inactive whenever your mouse is active, and the cursor will be obedient once more.

      NOTE: If you had previously used this forum’s sticky-key solution by disabling the Human Interface Devices > Microsoft Input Configuration Device, the troubleshooting will have–in addition to making the touchpad off-setting work–re-enabled that input config device, and you’ll get the infinite sticky-key problem again. NO PROBLEM –Go back and disable it again. Shut down your Surface, detach & replace the keyboard just to be sure the new handshake occurs, and turn the Surface back on. All will be well.

    You must be logged in to reply to this topic.